Updating jvm

XXMax Perm Size 256m --launcher.default Action open File -vmargs -Dosgi.required Java Version=1.5 -Xms40m -Xmx512m I have multiple versions of Java installed, both Sun JDK & JRockit, both 32 bit and 64-bit, etc.

and ran into this problem with a fresh install of 64-bit Eclipse for Java EE (JUNO).

R36x_v20101122_1400--launcher.library plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.2. R36x_v20101222 -product org.product --launcher.default Action open File --launcher.

XXMax Perm Size 256M -showsplash org.eclipse.platform -vm C:\Program Files\Java\jdk1.6.0_32\bin\--launcher.

When I typed "java -version" from command line (cmd.exe), Sun JDK 7 64-bit was returned...

if one is 32-bit the other must be the same, and not 64-bit.

I had also mentioned the VM arguments, and explained why they could obviously not work for me.

It is your choice how you want to set up your system, depending on what you really need.

You need that Eclipse and the JDK be 32-bits or both on 64-bits.

The architecture of the OS doesn't matter while the others remains on the same type of arquitecture.